Image delivery issues in SGP region

Major incident Image Transformations
27 minutes

Updates

Resolved

Image delivery issue in SGP is resolved.

June 9, 2020 · 05:42 AM UTC
Issue

Image processing is majorly impacted in SGP region. We are investigating.

June 9, 2020 · 05:15 AM UTC