Back to overview
Degraded

Delivery of images is slow in India region.

Jun 15, 2026 at 5:54pm UTC
Affected services
Image Transformations

Resolved
Jun 15, 2026 at 6:13pm UTC

The issue is resolved.

Updated
Jun 15, 2026 at 5:55pm UTC

The systems are recovering and we are monitoring.

Created
Jun 15, 2026 at 5:54pm UTC

We have identified an issue affecting image processing in India region.